Calendly

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Calendly Service Disruption
Resolved

This incident has been resolved.

Fri, Jan 6, 2023, 05:02 PM
(3 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Fri, Jan 6, 2023, 05:02 PM

Monitoring

Our team is currently investigating errors some users may have experienced while booking meetings between 10:50am ET and 11:20 AM ET. We've addressed the cause of the errors and we're remediating any issues that may have arisen from these booking errors.

Fri, Jan 6, 2023, 04:28 PM(33 minutes earlier)

Monitoring

A fix has been implemented and we are monitoring the results.

Fri, Jan 6, 2023, 04:27 PM