Calendly

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Zoom meetings failing to add to Calendly booked meetings resulting in "Action Needed" error.
Resolved·Degraded performance

This incident has been resolved.

Thu, Jul 10, 2025, 09:19 PM
(9 months ago)
·
Affected components
Jul 10, 2025, 08:18 PM
09:19 PM
Updates

Resolved

This incident has been resolved.

Thu, Jul 10, 2025, 09:19 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Jul 10, 2025, 08:45 PM(33 minutes earlier)

Identified

The issue has been identified and a fix is being implemented.

Thu, Jul 10, 2025, 08:30 PM(15 minutes earlier)

Investigating

We are currently investigating unexpected behavior involving our Zoom integration resulting in an "Action Needed/Required" error for newly scheduled Calendly Meetings.

Thu, Jul 10, 2025, 08:18 PM(11 minutes earlier)