Calendly

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Stripe Services are Experiencing an Outage
Resolved·Partial outage

Stripe has reported all services are now online and operating normally.

Wed, Apr 27, 2022, 09:37 PM
(4 years ago)
·
Affected components
Apr 27, 2022, 09:21 PM
09:37 PM
Updates

Resolved

Stripe has reported all services are now online and operating normally.

Wed, Apr 27, 2022, 09:37 PM

Identified

Stripe services are currently experiencing an outage that is intermittently preventing some Calendly users from booking paid events.

Wed, Apr 27, 2022, 09:21 PM(15 minutes earlier)