Calendly

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Analytics Dashboard Reporting Issue
Resolved·Degraded performance

This incident has been resolved.

Tue, May 9, 2023, 03:21 PM
(3 years ago)
·
Affected components
May 9, 2023, 01:40 PM
03:21 PM
calendly.com
Updates

Resolved

This incident has been resolved.

Tue, May 9, 2023, 03:21 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Tue, May 9, 2023, 02:03 PM(1 hour earlier)

Identified

The issue has been identified and a fix is being implemented.

Tue, May 9, 2023, 02:02 PM

Investigating

Some users may experience issues loading reports on the Analytics Dashboard. We are investigating the issue and will have an update soon.

Tue, May 9, 2023, 01:40 PM(22 minutes earlier)