Calendly

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Incident
Resolved·Degraded performance

This incident has been resolved.

Thu, Mar 17, 2022, 05:00 PM
(4 years ago)
·
Affected components
Mar 17, 2022, 04:17 PM
04:47 PM
Updates

Resolved

This incident has been resolved.

Thu, Mar 17, 2022, 05:00 PM

Monitoring

We are continuing to monitor for any further issues.

Thu, Mar 17, 2022, 04:47 PM(13 minutes earlier)

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Mar 17, 2022, 04:46 PM

Investigating

We are continuing to investigate this issue.

Thu, Mar 17, 2022, 04:24 PM(21 minutes earlier)

Investigating

We are continuing to investigate this issue.

Thu, Mar 17, 2022, 04:17 PM

Investigating

We are seeing intermittent issues with the Outlook Desktop Plugin, Calendly’s public API, as well as Calendly booking for some users with Outlook calendar connections.

Thu, Mar 17, 2022, 04:08 PM