Microsoft 365 users may experience slow load times on Calendly
Incident Report for Calendly
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 13:14 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 26, 2024 - 09:47 EST
Update
Our upstream provider is continuing monitoring to ensure service availability, which is reported as healthy. Customers using Microsoft integrations may experience degraded performance. We continue to monitor this incident.
Posted Nov 26, 2024 - 08:42 EST
Monitoring
Our upstream provider is working towards a full recovery. Customers using Microsoft integrations may continue to experience degraded performance. We are continuing to monitor this incident.
Posted Nov 25, 2024 - 21:59 EST
Investigating
Some users utilizing Microsoft 365 with Calendly may experience degraded service as a result of an upstream provider incident.

Users may encounter delayed loading page times. We are monitoring and will update as this incident progresses.
Posted Nov 25, 2024 - 09:30 EST
This incident affected: Calendar Integrations (Outlook.com & Office 365).