Canceled events on Google Calendar are delayed on Calendly
Incident Report for Calendly
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 13:16 EDT
Monitoring
A fix has been implemented, sync cancelations are syncing and we are monitoring the results.
Posted Apr 10, 2024 - 11:59 EDT
Investigating
We are currently investigating an issue where canceled events on connected Google Calendars are delayed in being represented as bookable time within Calendly.
Posted Apr 10, 2024 - 11:43 EDT
This incident affected: Calendar Integrations (Google).