Resolved
This incident has been resolved.
Monitoring
We are seeing improvements on this issue, but continuing to monitor.
Monitoring
We are continuing to see processing delays and are actively triaging the event processing.
Monitoring
We are continuing to monitor for any further issues.
Monitoring
Calendly experienced elevated error rates and higher than normal latency in processing events related to calendar connections, webhooks, email sends, video conferencing, and SMS processing. Queues are in the process of recovering and delivery is rapidly catching up.
Identified
Our engineers have identified the errors causing this delay. We’ve taken steps to remediate and are seeing signs of recovery
Investigating
We are continuing to investigate this issue.
Investigating
We are experiencing delays in emails sending and events pushing to calendars