No components marked as affected
Resolved
We have confirmed the issue is no longer occurring and systems are normalized.
Monitoring
A fix has been implemented and we are monitoring the results.
Identified
Users maybe experiencing a server error when attempting to view upcoming meetings with confirmed invitees from the Meeting page. We are actively working on a fix to restore this functionality. In the meantime you can retrieve this same information through either of these methods:
Export the data from the Meetings tab
Review the email notification sent from the original invitation