Resolved
We are continuing to monitor the system to ensure everything remains stable.
Monitoring
We are continuing to monitor the fix that has been put in place. Calendly is fully operational, and we will provide additional updates if needed.
Identified
We are currently investigating an issue with calendly
Investigating
We are currently investigating an issue with Calendly